php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35856 Segmentation Fault
Submitted: 2005-12-31 02:03 UTC Modified: 2005-12-31 03:39 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: jseverson at myers dot com Assigned:
Status: Not a bug Package: Output Control
PHP Version: 5CVS-2005-12-30 (snap) OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jseverson at myers dot com
New email:
PHP Version: OS:

 

 [2005-12-31 02:03 UTC] jseverson at myers dot com
Description:
------------
We just upgraded to php 5.1.1 on our development slice and have run into all kinds of buffering seg fault issues that seem to be similar to what was reported in this bug. 

We tried setting output_buffer to off/on/4096, and none of those settings fixed the problem. However, if we up our output_buffer to about 16000, the problem goes away on most pages, but not all. If we then increase our output_buffer to 5000000 then the problem goes away entirely.

We were able to isolate where the browser stopped sending HTML, and it seems to be SOMEWHAT related to our use of ob_* functions in one case. However, there were other cases where html would stop outputting literally in the middle of a <td> tag...so if you viewed source, all you would see is:

<t

Modules are:

ctype,curl,date,dom,exif,gd,iconv,libxml,ming,mysql,oci8,pcre,PDO,pdo_mysql,PDO_OCI,posix,session,SimpleXML,smbauth,soap,SPL,standard,sybase,tokenizer,xml,zlib





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-12-31 02:04 UTC] jseverson at myers dot com
The errors we are experiencing are similar to this bug:

http://bugs.php.net/bug.php?id=35278

which was supposedly fixed in 5.1.0.
 [2005-12-31 02:11 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.1-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.1-win32-latest.zip


 [2005-12-31 02:28 UTC] jseverson at myers dot com
Yep, we just tried the latest snapshot from CVS 15 minutes ago and experienced the same seg faults.
 [2005-12-31 02:29 UTC] sniper@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.


 [2005-12-31 02:35 UTC] jseverson at myers dot com
Apache2 and PHP were compiled with threads while we were experiencing these problems. We just recompiled them without threads and the problem has gone away.

Don't know if this helps you determine the cause, but it definitely seems to be PHP related because when we display a static page with no PHP, we never have any seg faulting.
 [2005-12-31 03:39 UTC] sniper@php.net
Yeah, don't do that. Threaded web servers are not supported.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Feb 04 16:05:48 2023 UTC