php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35792 imap_fetchstructure identify multipart/mixed mail as plain
Submitted: 2005-12-24 00:06 UTC Modified: 2005-12-28 14:13 UTC
From: t dot prochazka at centrum dot cz Assigned:
Status: Not a bug Package: IMAP related
PHP Version: 5.1.1 OS: any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: t dot prochazka at centrum dot cz
New email:
PHP Version: OS:

 

 [2005-12-24 00:06 UTC] t dot prochazka at centrum dot cz
Description:
------------
When I use imap_fetchstructure for this message:
http://atom.mamto.cz/projekty/bugs/php/problem_email.msg
get this result:
http://atom.mamto.cz/projekty/bugs/php/problem_email.png

I tested this meessage with many clients and all show this message corectly, problem is only in PHP.

I tested also PHP 5.0.3, the same problem.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-12-24 00:14 UTC] tony2001@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 [2005-12-24 17:16 UTC] t dot prochazka at centrum dot cz
Here is testcase:
http://atom.mamto.cz/projekty/bugs/php/problem_email.php

I can give you password for it, but only personal, not public.
 [2005-12-24 17:20 UTC] tony2001@php.net
I don't need a password, I need a reproduce code with expected and actual results + a decent description.

 [2005-12-24 20:53 UTC] t dot prochazka at centrum dot cz
Reproduce code is on the page, which I send. But this is IMAP problem and this need IMAP server for test it. imap_fetchstructure() can't read message from file.
 [2005-12-24 21:44 UTC] sniper@php.net
Report to the c-client author. We only use whatever functions it provides. The problem is there.
 [2005-12-24 22:51 UTC] t dot prochazka at centrum dot cz
This is problem. I don't found any contact to authors of c-client :-(
 [2005-12-28 14:13 UTC] t dot prochazka at centrum dot cz
The same problems:
http://bugs.php.net/bug.php?id=13465
http://bugs.php.net/bug.php?id=16141
I think, that this problem is in Courier IMAP server.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sun Feb 05 18:03:43 2023 UTC