php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35761 glibc error
Submitted: 2005-12-21 11:29 UTC Modified: 2006-01-04 13:43 UTC
From: gestar at mail dot ru Assigned:
Status: Wont fix Package: Informix related
PHP Version: 4.4.1 OS: RHEL 4 AS
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gestar at mail dot ru
New email:
PHP Version: OS:

 

 [2005-12-21 11:29 UTC] gestar at mail dot ru
Description:
------------
I have so problem with function ifx_free_char.
When it runs, glibc generates error message and apache's child process died.

*** glibc detected *** double free or corruption (!prev): 0x08343800 ***
[Wed Dec 21 14:53:19 2005] [notice] child pid 2834 exit signal Aborted (6)

Can you help me?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-01-04 12:41 UTC] gestar at mail dot ru
When PHP compiled with --enable-debug option, no error, script don't crash PHP! When compile without this option PHP crashes. What my next steps?
 [2006-01-04 12:47 UTC] gestar at mail dot ru
Also when PHP compiled with --enable-debug, apache log contents this:
---------------------------------------
/usr/local/src/php-4.4.1/ext/informix/ifx.ec(4083) : Block 0x08350668 status:
Beginning:      Overrun (magic=0x083508C0, expected=0x7312F8DC)
      End:      Unknown
---------------------------------------
 [2006-01-04 12:55 UTC] sniper@php.net
Install PHP 5.1.1 and use the pdo_informix instead found here:
http://pecl.php.net/package/PDO_INFORMIX
 [2006-01-04 13:40 UTC] gestar at mail dot ru
Our soft cannot be run under PHP 5 (compatible problems).
 [2006-01-04 13:43 UTC] derick@php.net
Then you'll have to spend some time trying to find and fix the bug yourself. There does not seem to be an active maintainer for this extension.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Nov 22 02:01:23 2019 UTC