php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35758 SoapClient::__construct() [function.--construct]: SSL: fatal protocol error
Submitted: 2005-12-21 07:33 UTC Modified: 2005-12-21 10:42 UTC
From: kurzhumov at gmail dot com Assigned:
Status: Not a bug Package: SOAP related
PHP Version: 5CVS-2005-12-21 (snap) OS: Red Hat Enterprise Linux ES
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: kurzhumov at gmail dot com
New email:
PHP Version: OS:

 

 [2005-12-21 07:33 UTC] kurzhumov at gmail dot com
Description:
------------
The SOAP extension fails to connect to Web-service on Microsoft Windows Server 2003 over SSL. 

Warning: SoapClient::__construct(): SSL: fatal protocol error in test.php on line 7

Client: Red Hat Enterprise Linux ES
Server: IIS 6 on Microsoft Windows Server 2003

Reproduce code:
---------------
<?php

error_reporting(E_ALL);
ini_set('display_errors', 1);
ini_set('display_startup_errors', 1);

$client = new SoapClient('https://example.com/WebServices/Test.asmx?WSDL');
var_dump($client);

?>

Actual result:
--------------
Warning: SoapClient::__construct(): SSL: fatal protocol error in test.php on line 7
object(SoapClient)#1 (2) {
  ["_soap_version"]=>
  int(1)
  ["sdl"]=>
  resource(5) of type (Unknown)
}
PHP Warning:  SoapClient::__construct(): SSL: fatal protocol error in test.php on line 7

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-12-21 08:53 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.1-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.1-win32-latest.zip


 [2005-12-21 10:36 UTC] kurzhumov at gmail dot com
Installing latest snapshot does not solve this problem.
 [2005-12-21 10:42 UTC] tony2001@php.net
That's because buggy IIS violates SSL protocol.
Not PHP problem, report that to IIS authors.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC