php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35741 problema con function COPY
Submitted: 2005-12-20 09:34 UTC Modified: 2005-12-20 10:58 UTC
From: egarcia at jig dot es Assigned:
Status: Not a bug Package: *Directory/Filesystem functions
PHP Version: 5.1.1 OS: Windows XP/2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: egarcia at jig dot es
New email:
PHP Version: OS:

 

 [2005-12-20 09:34 UTC] egarcia at jig dot es
Description:
------------
Buenos d?as:

He actualizado el PHP de mi servidor a la versi?n 5.1.1. Todo va bien hasta ahora salvo que no puedo adjuntar un archivo (una imagen en este caso particular) al server a trav?s de un formulario. El error que da es:

Warning: copy(c:\\maps\\tumbs\\mapsys.jpg) [function.copy]: failed to open stream: No such file or directory in c:\phpscripts\mapcdr.php on line 366 ...

Esto ocurre siempre que se hace desde cualquier ordenador hacia el servidor. Lo curioso, es que esto no pasa si se hace directamente en el propio servidor (localhost).

Ind?quenme cual es el problema y su posible soluci?n. Muchas gracias por su ayuda.

Reproduce code:
---------------
copy($imagen,"../imagenproductos/".$nombre_img);


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-12-20 09:41 UTC] derick@php.net
Please only file bugreports in English. Can you translate?
 [2005-12-20 09:51 UTC] egarcia at jig dot es
Good morning:

I have updated the PHP of my server to version 5.1.1.  Everything goes well until now unless I cannot enclose a file (an image in this particular case) to the server through a form.  The error that it gives is:

Warning:  copy(c:\\maps\\tumbs\\mapsys.jpg) [ function.copy ]:  failed to open stream:  Such does not case out or directory in c:\phpscripts\mapcdr.php on line 366...

This happens whenever it becomes from any computer towards the server.  The peculiar thing, is that this does not happen if is made directly in the own server (localhost).

Help me what is the problem and its possible solution.  Thank you very much by its aid.
 [2005-12-20 10:58 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Nov 28 11:05:53 2022 UTC