php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35737 undefined symbol: sqlite3SelectDelete
Submitted: 2005-12-20 04:26 UTC Modified: 2006-02-28 18:59 UTC
Votes:18
Avg. Score:4.4 ± 0.8
Reproduced:16 of 16 (100.0%)
Same Version:11 (68.8%)
Same OS:8 (50.0%)
From: jphml at videotron dot ca Assigned:
Status: Not a bug Package: SQLite related
PHP Version: 5.1.1 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jphml at videotron dot ca
New email:
PHP Version: OS:

 

 [2005-12-20 04:26 UTC] jphml at videotron dot ca
Description:
------------
When tring to use Apache 2.0.55 with PHP 5.1.1 module  
(libphp5.so) you get the following error on Apache startup  
 
Syntax error on line 232 of /opt/fruity/conf/httpd.conf: 
Cannot load /opt/fruity/modules/libphp5.so into  
server: /opt/fruity/modules/libphp5.so: undefined symbol:  
sqlite3SelectDelete  
  
Your are then unable to start apache. 
 
Here is my configure line for Apache: 
./configure --prefix=/opt/fruity --enable-so 
 
Here is my configure line for PHP 5.1.1: 
./configure --prefix=/opt/fruity 
--with-apxs2=/opt/fruity/bin/apxs --with-mysql 
 
Here is my line about PHP in httpd.conf 
LoadModule php5_module        modules/libphp5.so 
 
I tried the following: 
- Apache 1.3.34 with PHP 5.1.1: same error 
- Compile PHP 5.1.1 with --without-sqlite: Same error 
- Compile PHP without --with-mysql: Same error 
 
The following configuration works: Apache 2.0.55 and PHP 
5.0.5 with the configure lines above. (In Apache 1.x use 
--enable-module=so instead of --enable-so). 
 
Note that both software were always compiled with 
--prefix=/opt/fruity, I didn't tried without. 
 

Expected result:
----------------
You expect that Apache will start without errors  

Actual result:
--------------
When you start apache you get:  
 
[root@toolbox bin]# ./apachectl start 
Syntax error on line 232 of /opt/fruity/conf/httpd.conf: 
Cannot load /opt/fruity/modules/libphp5.so into  
server: /opt/fruity/modules/libphp5.so: undefined symbol:  
sqlite3SelectDelete  
  
and Apache doesn't start  

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-12-20 09:14 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.1-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.1-win32-latest.zip

And what OS is that exactly?
 [2005-12-22 17:22 UTC] jsuzuki at spamcop dot net
I had the same problem.  The suggestion by sniper@php.net worked out.

Just as an FYI this was on a horribly out of Red Hat 7 with Apache 1.3.

-jack
 [2005-12-24 07:41 UTC] jphml at videotron dot ca
I was not successful using CVS of 21-12-2005. I am using 
CentOS 4.1 latest patch.
 [2005-12-24 14:35 UTC] tony2001@php.net
Are you able to reproduce it without Apache?
Does it work with PHP CLI?
 [2006-01-01 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2006-01-04 19:23 UTC] esesen at o2 dot pl
exactly the same problem under slackware 10.2
 [2006-01-05 11:23 UTC] james at e0ts dot com
Same with Debian 3.1
 [2006-01-11 03:54 UTC] george at gmarcotte dot com
http://snaps.php.net/php5.1-latest.tar.gz has no effect still get the error:

httpd: Syntax error on line 53 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/libphp5.so into server: /usr/local/apache2/modules/libphp5.so: undefined symbol: sqlite3SelectDelete

when I try to start the webserver. What is sqlite3SelectDelete? is there some header files missing?
 [2006-01-28 23:08 UTC] vano at kolumbus dot fi
Try to install Tcl-devel package, because sqlite needs it. Then recompile php.

OR

Re-configure pdo_sqlite/sqlite with "--disable-tcl" option (because it is actually not needed for building the lirary). Then recompile php.
 [2006-02-01 19:33 UTC] kpankratz at gmail dot com
installing Tcl-devel package did not solve the problem.  

Using --with-zlib removed the sqlite errors.  The next module in the list now produces the error.

ldd -d libphp5.so shows most of the modules as an undefined symbol.

PHP 5.1.2 source files, Apache 2.2.0 source files, OS = SLES 9 SP3
 [2006-02-04 03:38 UTC] fuchsd at gmail dot com
Same problem: php 5.1.2, apache 2.2.0, mysql 5.0.18, Ubuntu Breezy
 [2006-02-13 02:28 UTC] gus dot heck at gmail dot com
Here is how I can get in and out of this bad state.

Get in:

make clean
./configure --with-mysqli=/usr/local/mysql/bin/mysql_config 
make && make install
./configure --with-mysqli=/usr/local/mysql/bin/mysql_config --with-apxs2=`which apxs2`
make && make install

Now I get the undefined symbol, to get out

make clean
./configure --with-mysqli=/usr/local/mysql/bin/mysql_config --with-apxs2=`which apxs2`
make && make install

It would seem that there is a dependency that the makefiles don't handle. I got into this state because I had thought that ./configure would find apache automatically, but it didn't. So I looked up some docs found the apxs2 flag and enabled it, but didn't do a clean.
 [2006-02-28 18:51 UTC] mail at kallesoee dot dk
i am seeing the same problem on freebsd 5.4 apache 1.3.34
 [2006-02-28 18:59 UTC] tony2001@php.net
Use `make clean` when building different SAPIs one after another.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Dec 09 19:05:54 2022 UTC