php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35504 Can only use c:\windows for php.ini dir.
Submitted: 2005-12-01 16:57 UTC Modified: 2005-12-01 18:03 UTC
From: thejkwhosaysni at gmail dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.1.1 OS: win32
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
36 - 2 = ?
Subscribe to this entry?

 
 [2005-12-01 16:57 UTC] thejkwhosaysni at gmail dot com
Description:
------------
Since php5.1 I have been unable to use php.ini from any directory other than c:\windows. This is a pain because i have apache2 running as a seperate user which I don't really want accessing any directories than it needs to.

php5.0.* worked fine with php.ini in the \apache2\ directory.

I tried overwriting my original php.ini (from when i installed 5.0) with the php.ini-dist from 5.1.1 with no avail. php refuses to see that it's there. I also trid the \php directory with both my php.ini and the default php.ini-dist. Neither worked.

I first noticed this with 5.1.0 and the problem is still present in 5.1.1

Reproduce code:
---------------
I just extracted php5.1.0 into the directory that I had php5.0.* installed into.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-12-01 18:03 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

See bug #35329
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Dec 06 04:05:54 2022 UTC