php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35476 Result page is empty
Submitted: 2005-11-29 15:46 UTC Modified: 2005-11-29 15:52 UTC
From: vejaykrishna at yahoo dot co dot nz Assigned:
Status: Not a bug Package: MySQLi related
PHP Version: 5.1.1 OS: win xp prof
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vejaykrishna at yahoo dot co dot nz
New email:
PHP Version: OS:

 

 [2005-11-29 15:46 UTC] vejaykrishna at yahoo dot co dot nz
Description:
------------
sir, i am new user of PHP. i need to open a database in MySQL using new mysqli(). But my web page is blank if i run that program since the user name and password is not given. i need to know if root is the user what should be in user name and what should be in password column.

Reproduce code:
---------------
<?php
@ $db=new mysqli('localhost','','','hotel');
if (mysqli_connect_errno())
{
  echo 'Error:could not connect to db';
  
}
$pid=1;
$pln='ap';
$sgl=300.00;
$dbl=600.00;
$dlflg=0;
$qry="insert into plan values(".$pid.",'".$pln."',".$sgl.",".$dbl.",".$dlflg.")";
$result=$db->query($qry);
if( $result)
  echo 'inserted';
?>

Expected result:
----------------
I need to see that the querry is inserted.

Actual result:
--------------
i debugged the program when line 2 is executed the control transfers some where.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-11-29 15:52 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Dec 06 18:05:53 2022 UTC