php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35468 Undefined symbol fdatasync
Submitted: 2005-11-29 08:49 UTC Modified: 2005-11-29 18:55 UTC
From: kenji dot funasaki at sun dot com Assigned: wez (profile)
Status: Not a bug Package: PDO related
PHP Version: 5.1.1 OS: Solaris 10 3/05 x86
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: kenji dot funasaki at sun dot com
New email:
PHP Version: OS:

 

 [2005-11-29 08:49 UTC] kenji dot funasaki at sun dot com
Description:
------------
I installed Solaris 10 3/05 x86, and use Apache 2.0, MySQL, libxml2-2.26.22. After these, I tried to install PHP-5.1.1.
However, I can't install PHP-5.1.1.



# gunzip /usr/local/php/php-5.1.1.tar.gz
# tar xvf /usr/local/php/php-5.1.1.tar
# cd php-5.1.1
# which make
/usr/ccs/bin/make

# ./configure --with-mysql=/usr/sfw --with-apxs2=/usr/apache2/bin/apxs 
  --prefix=/usr/local/php/php-5.1.1 --with-libxml-dir=/usr/local/lib/libxml2-2.6.22 --enable-so

# make
 Undefined                       first referenced
 symbol                             in file
fdatasync                           ext/pdo_sqlite/sqlite/src/.libs/os_unix.o    (symbol belongs to implicit dependency /usr/lib/librt.so.1)
ld: fatal: Symbol referencing errors. No output written to sapi/cli/php
collect2: ld returned 1 exit status
*** Error code 1
make: Fatal error: Command failed for target `sapi/cli/php'

make command failed.
I watched man of fdatasync, it is necessary to add "-lrt" CC option. So I add the option to Makefile, after that Build Complete.


Reproduce code:
---------------
I watched man of fdatasync, it is necessary to add "-lrt" CC option. So I add the option to Makefile, after that Build Complete.

In Makefile,
 CC = gcc
->
 CC = gcc -lrt

Actual result:
--------------
make command and make install command are completed.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-11-29 09:28 UTC] sniper@php.net
Assigned to the maintainer of PDO. (I haven't got solaris)

 [2005-11-29 10:00 UTC] tony2001@php.net
On Solaris8 fdatasync is in libposix4, btw.
 [2005-11-29 13:52 UTC] wez@php.net
Interesting; it builds fine for me on opensolaris.

 [2005-11-29 18:55 UTC] iliaa@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Dupe of bug #35377
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Dec 01 13:01:47 2020 UTC