|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35461 Ming extension fails to compile with ming 0.3beta1
Submitted: 2005-11-28 23:56 UTC Modified: 2005-12-21 22:44 UTC
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: hostmaster at xenterra dot net Assigned: helly (profile)
Status: Closed Package: Ming related
PHP Version: 5CVS-2005-12-21 (cvs) OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
38 - 21 = ?
Subscribe to this entry?

 [2005-11-28 23:56 UTC] hostmaster at xenterra dot net
No script; this is a compile error.
Configure options:
./configure --with-apxs=/usr/local/apache/bin/apxs \
            --with-pgsql=/usr/local/pgsql \
            --enable-dba \
            --with-flatfile \
            --with-openssl \
            --enable-exif \
            --with-gd=/usr/local/gd-2.0.33 \
            --with-jpeg-dir=/usr/lib \
            --with-png-dir=/usr/lib \
            --with-zlib-dir=/usr/lib \
            --with-xpm-dir=/usr/X11R6/lib \
            --with-imap=/usr/local/imap-2002d \
            --with-imap-ssl=/usr/local/ssl \
            --with-curl \
            --with-curlwrappers \
            --enable-ftp \
            --enable-soap \
            --with-libxml-dir=/usr/local/lib \
            --with-ming=/usr/local/lib \

Compilation also failed using CVS snapshot php5-200511282130 on Slackware 10.2, and on Slackware 10.1 using official release.

Ming version is ming-0.3beta1.

Reproduce code:
No code.

Expected result:

Actual result:
Following is gcc output right before "make" quit:

/usr/local/php-5.1.1/ext/ming/ming.c: In function `zif_swfbitmap___construct':
/usr/local/php-5.1.1/ext/ming/ming.c:386: warning: assignment from incompatible pointer type
/usr/local/php-5.1.1/ext/ming/ming.c: In function `zif_swfmovie_output':
/usr/local/php-5.1.1/ext/ming/ming.c:2267: error: too few arguments to function `SWFMovie_output'
/usr/local/php-5.1.1/ext/ming/ming.c: In function `zif_swfmovie_saveToFile':
/usr/local/php-5.1.1/ext/ming/ming.c:2329: error: too few arguments to function `SWFMovie_output'
/usr/local/php-5.1.1/ext/ming/ming.c: In function `zif_swfmovie_save':
/usr/local/php-5.1.1/ext/ming/ming.c:2380: error: too few arguments to function `SWFMovie_output'
/usr/local/php-5.1.1/ext/ming/ming.c:2399: error: too few arguments to function `SWFMovie_output'
/usr/local/php-5.1.1/ext/ming/ming.c: In function `zif_swftextfield_setFont':
/usr/local/php-5.1.1/ext/ming/ming.c:3741: warning: passing arg 2 of `SWFTextField_setFont' from incompatible pointer type
make: *** [ext/ming/ming.lo] Error 1


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2005-11-29 19:29 UTC] hostmaster at xenterra dot net
The snapshot php5-200511291530 failed to compile with ext/ming with essentially the same error messages as were originally reported (see Actual Result below). It appears that the ming extension code has not yet been re-worked.
 [2005-12-21 22:44 UTC]
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
Thank you for the report, and for helping us make PHP better.

PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat May 30 00:01:25 2020 UTC