php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35439 COM object not working in ISAPI
Submitted: 2005-11-28 09:26 UTC Modified: 2005-12-06 01:00 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: info at goldfish dot co dot za Assigned:
Status: No Feedback Package: COM related
PHP Version: 4.4.1 OS: Win 2003 Server Web Ed.
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: info at goldfish dot co dot za
New email:
PHP Version: OS:

 

 [2005-11-28 09:26 UTC] info at goldfish dot co dot za
Description:
------------
Hi there

A website is being hosted on Windows 2003 Server, Web Edition. It uses a third party COM component that has been installed on the server to process credit card transactions.

When using CGI, there are constant "Bad Gateway" error messages which we have ascertained (from previously logged bugs on PHP.net) that this is an IIS error.  Changing to ISAPI fixes all this, but then the problem is the COM component stops working (there were no hassles with CGI).  It gives access violations errors and PHP crashes.

The PHP version is 4.3.10.  The hosting company uses a third party control panel tool (Plesk), which is currently using the above PHP version and for this reason they cannot upgrade.

I have been reading all the bugs and it does seem that this has been fixed.  Is it possible to get the last snapshot for 4.3.10?  Otherwise, do you have any other suggestions (apart from the obvious which is upgrading)? I'm desperate!! :-)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-11-28 09:47 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip


 [2005-12-06 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2005-12-13 11:30 UTC] milan at icewarp dot com
We are also facing this issue. PHP 4.4.1 cannot connect to mail server gateway using CGI mode. When switch to ISAPI all goes fine.

Fixed in 5.0.5 version but there are other reasons why we have to stick with 4.x versions (performance).

Thanks for any update.

Milan
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jan 27 20:03:37 2022 UTC