php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35423 RecursiveDirectoryIterator doesnt appear to recurse with RecursiveFilterIterator
Submitted: 2005-11-27 12:33 UTC Modified: 2005-11-27 13:28 UTC
From: Jared dot Williams1 at ntlworld dot com Assigned: helly (profile)
Status: Closed Package: SPL related
PHP Version: 5.1.0 OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Jared dot Williams1 at ntlworld dot com
New email:
PHP Version: OS:

 

 [2005-11-27 12:33 UTC] Jared dot Williams1 at ntlworld dot com
Description:
------------
RecursiveDirectoryIterator doesnt appear to recurse into subdirectories.

Reproduce code:
---------------
http://cvs.php.net/co.php/php-src/ext/spl/examples/nocvsdir.php?r=1.2

...php5\ext\spl\examples>php nocvsdir.php ../../..


Expected result:
----------------
List of all files and directories in the php5 cvs tree, but excluding any named 'CVS'

Actual result:
--------------
Just a list of files directly below the specified directory.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-11-27 12:37 UTC] Jared dot Williams1 at ntlworld dot com
Fixed summary.
 [2005-11-27 13:28 UTC] helly@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

The example was simply copied from head to 5.1. There it is missing some updates i have only on my machine which are scheduled for 5.1.2. The problem is however fixed in CVS now and it is only in the php script. It has nothing to do with the topic directly. Indeed it is missing a simply missing a 'conversion' in the NoCvsDirectory class
that is done automatically in HEAD.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC