php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35283 XML Datatype / SQL 2005
Submitted: 2005-11-18 20:38 UTC Modified: 2005-11-18 20:41 UTC
From: SKerres at Kerres-edv dot de Assigned:
Status: Not a bug Package: PDO related
PHP Version: 5.1.0RC6 OS: Windows 2003
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: SKerres at Kerres-edv dot de
New email:
PHP Version: OS:

 

 [2005-11-18 20:38 UTC] SKerres at Kerres-edv dot de
Description:
------------
I tried to select data from an SQL2005 table witch contains the new SQL2005 datatype XML.I got no data, but an warning.

Reproduce code:
---------------
CREATE TABLE XMLDaten
(
XDA_Titel varchar(30)	NOT NULL,
XDA_XML	  xml
)
------------------------------------------------
$con = new PDO('mssql:host=Server;initial catalog=Adressen','pschmidt','password');
foreach($con->query('SELECT * FROM dbo.XMLDaten') AS $Zeile)
{
    echo '<br>';
    var_dump($Zeile);
}


Expected result:
----------------
Data

Actual result:
--------------
 Warning: Invalid argument supplied for foreach() in c:\Inetpub\wwwroot\sql2005.php on line 6

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-11-18 20:41 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Nov 23 20:01:23 2020 UTC