php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35220 Sigsegv in zend_execute.execute
Submitted: 2005-11-15 06:19 UTC Modified: 2005-11-25 01:00 UTC
From: grover at us dot ibm dot com Assigned:
Status: No Feedback Package: Reproducible crash
PHP Version: 5.0.5 OS: AIX 5.2.0.60
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: grover at us dot ibm dot com
New email:
PHP Version: OS:

 

 [2005-11-15 06:19 UTC] grover at us dot ibm dot com
Description:
------------
I am running php 5.0.4 and phpMyAdmin 2.6.4-pl3 with MySql 4.1.15 on and AIX 52 system with IBMIHS webserver (apache!) v 2. 
 
I can login to phpMyAdmin without a probem and do everything EXCEPT look at a database. when I choose 'databases' I get s sigsegv in the http server.

My configure line is:

./configure --enable-zend-multibyte \ 
--enable-safe-mode \ 
--enable-sigchild \ 
--enable-debug \ 
--prefix=./usr/local/php \ 
--with-apxs2=/usr/IBMIHS/bin/apxs \ 
--with-config-file-path=/usr/local/php/ \ 
--enable-maintainer-zts \ 
--with-libxml-dir=/opt/freeware/lib/ \ 
--with-zlib-dir=/opt/freeware/lib \ 
--with-mysql=/usr/local/mysql \ 
--enable-mbstring \ 
--enable-ftp \ 
--enable-bcmath \ 
--enable-fastcgi \ 
--with-mysqli=\ 
/usr/local/mysql-4.1.12/bin/mysql_config \ 
--with-pear 
 

# diff php.ini-dist php.ini:

< error_reporting  =  E_ALL & ~E_NOTICE & ~E_STRICT
---
> error_reporting  =  E_ALL
295c353
< display_errors = On
---
> display_errors = O
300c358
< display_startup_errors = Off
---
> display_startup_errors = On
305c363
< log_errors = Off
---
> log_errors = On
374c432
< variables_order = "EGPCS"
---
> variables_order = "GPCS"
385c443
< register_globals = Off
---
> register_globals = On
395c453
< register_argc_argv = On
---
> register_argc_argv = Off
671c729
< mysql.default_host =
---
> mysql.default_host = localhost
802c860
< dbx.colnames_case = "unchanged"
---
> dbx.colnames_case = "lowercase"
912c970
< session.gc_divisor     = 100
---
> session.gc_divisor     = 1000
932c990
< session.bug_compat_42 = 1
---
> session.bug_compat_42 = 0
979c1037
< session.hash_bits_per_character = 4
---
> session.hash_bits_per_character = 5
986c1044
< url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="
---
> url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=fakeentry"


Expected result:
----------------
A list of tables spaces is expected.

Actual result:
--------------
httpd cores with the following stack:
zend_execute.execute(0x30723510, 0x3033cb58), line 1364 in "zend_execute.c" 
unnamed block $b3644, line 3581 in "zend_execute.c" 
zend_include_or_eval_handler(0x3037bab0, 0x307aeda4, 0x306f0a20, 0x3033cb58), line 3581 in "zend_execute.c" 
zend_execute.execute(0x306f0a20, 0x3033cb58), line 1406 in "zend_execute.c" 
unnamed block $b3644, line 3581 in "zend_execute.c" 
zend_include_or_eval_handler(0x303859b0, 0x3072b088, 0x306eecf0, 0x3033cb58), line 3581 in "zend_execute.c" 
zend_execute.execute(0x306eecf0, 0x3033cb58), line 1406 in "zend_execute.c" 
zend_execute_scripts(0x8, 0x3033cb58, 0x0, 0x3, 0x0, 0x30387330, 0x0, 0x5d8a800), line 1069 in "zend.c" 
unnamed block $b2972, line 1632 in "main.c" 
php_execute_script(0x30387330, 0x3033cb58), line 1632 in "main.c" 
unnamed block $b3730, line 555 in "sapi_apache2.c" 
php_handler(0x305660e8), line 555 in "sapi_apache2.c" 
ap_run_handler() at 0x10002fb8 
ap_invoke_handler() at 0x10003b7c 
ap_process_request() at 0x10035cf4 
ap_process_http_connection() at 0x10037b98 
ap_run_process_connection() at 0x10025d94 
ap_process_connection() at 0x1002641c 
process_socket() at 0x1002b774 
worker_thread() at 0x1002b048 
dummy_worker() at 0xd057ae8c 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-11-15 09:32 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip


 [2005-11-15 09:33 UTC] sniper@php.net
And do NOT use --enable-maintainer-zts !!!
 [2005-11-15 17:46 UTC] grover at us dot ibm dot com
Obtained latest php5 and libxml2. 
Removed --enable-maintainer-zts.
Now having problems in compiling parse_date:
YYCTYPE yych;
#define YYCURSOR cursor;
#define YYMAKER s->ptr;

yych = *(YYMARKER = *++YYCURSOR);  << this gernerated too many errors. Compile complains about mismatch between assignment of char and char* types.  I overcame the problem by going back to parse_date.c.orig. Continueing compile.
 [2005-11-17 15:58 UTC] grover at us dot ibm dot com
After going to the latest php5, the crash is gone, but almost none of the apps worl correctly. I get constant error about reformatting pages and many are either displayed with junk at the begining OR not at all.

I have changed my compile options a little and seem to be getting a core dump that looks very similar to bug 28064. Can I shift to using the zend engine in the lastest php5 with 5.0.4? Or should I expect that to also be problematic?

Thanks!
 [2005-11-17 16:12 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip

If you have any compile problems, please REPORT them here.
If you have any other problems, you need to tell us about them. Just saying "it does not work" doesn't help much..
 [2005-11-25 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jul 04 03:03:50 2022 UTC