php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35187 mb_internal_encoding() problem
Submitted: 2005-11-11 01:34 UTC Modified: 2005-11-11 01:58 UTC
From: kamil at webjay dot pl Assigned:
Status: Not a bug Package: mbstring related
PHP Version: 4.4.1 OS: Windows XP / FreeBSD 5.4
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: kamil at webjay dot pl
New email:
PHP Version: OS:

 

 [2005-11-11 01:34 UTC] kamil at webjay dot pl
Description:
------------
I was tested it at:
- Apache 1.3.34 & Win XP
- Apache 2.0.54 & FreeBSD 5.4

If mb_internal_encoding() not exist - php don't report any errors.

Reproduce code:
---------------
<?
error_reporting(E_ALL);
mb_internal_encoding("UTF-8");
echo 'abc';
...
?>

Expected result:
----------------
PHP Fatal error:  Call to undefined function: mb_internal_encoding() in C:\SERVER\www\webjay.pl\index.php on line 3.

Actual result:
--------------
NULL

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-11-11 01:46 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2005-11-11 01:58 UTC] kamil at webjay dot pl
can you read? php do not report any error about don't exist function... i have to guess - i got or not mb extension? NO ERRORS REPORING!
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Aug 14 01:05:46 2022 UTC