php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35174 Lack of extension dependency checking & misleading error message.
Submitted: 2005-11-09 19:11 UTC Modified: 2005-11-09 23:01 UTC
From: iceberg at verycool dot co dot uk Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.0.5 OS: win xp
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: iceberg at verycool dot co dot uk
New email:
PHP Version: OS:

 

 [2005-11-09 19:11 UTC] iceberg at verycool dot co dot uk
Description:
------------
Lack of extension dependency checking & misleading error message.

Attempting to load an extension when a preprequisite dll is missing seems to yield the same message as if the extension were missing. (vis. "the specified module could not be found").

This seems to be causing an innordinate amount of confusion (Judging by the number of "bogus bugs" and USENET posts resulting from this).

Reproduce code:
---------------
exists c:\php\php_openssl.dll

; php.ini
extension_dir = "C:\php"
extension=php_openssl.dll



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-11-09 20:56 UTC] sniper@php.net
This is impossible to fix.
 [2005-11-09 23:01 UTC] iceberg at verycool dot co dot uk
!impossible;
impossible!=bogus;
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Dec 06 10:03:51 2022 UTC