php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #3514 Private and Protected data in classes
Submitted: 2000-02-17 08:02 UTC Modified: 2001-11-11 14:48 UTC
From: php at westerdal dot com Assigned:
Status: Duplicate Package: Feature/Change Request
PHP Version: 4.0 OS: any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: php at westerdal dot com
New email:
PHP Version: OS:

 

 [2000-02-17 08:02 UTC] php at westerdal dot com
Classes don't have Private or Protected members.<BR>
I want to have some variables and functions private.<BR>
I can do this in real OOP langauges like C++.<p>

Are there any plans for this?<BR>
Am I missing something?<p>

Jay

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-02-25 13:43 UTC] joey at cvs dot php dot net
There are no plans to make PHP a "true" OOP language at this time...leaving as a "Feature Request"
 [2001-02-10 14:08 UTC] jimw@php.net
refiling against 4.0.
 [2001-11-11 14:48 UTC] sander@php.net
Dupe of #5142, which has more info so I'm closing this one.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC