php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35138 Coredump on validation of empty domdocument
Submitted: 2005-11-07 13:34 UTC Modified: 2005-11-07 13:42 UTC
From: kpisman at gmail dot com Assigned:
Status: Not a bug Package: DOM XML related
PHP Version: 5.0.5 OS: FreeBSD 6.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: kpisman at gmail dot com
New email:
PHP Version: OS:

 

 [2005-11-07 13:34 UTC] kpisman at gmail dot com
Description:
------------
Segmentation fult when empy domDocument is validated with schema.

Please note, this bug is may be potential way for low-bandwith DoS attack for any service, that is validating input with schma.


Reproduce code:
---------------
<?
$myDom=new DomDocument();
$myDom->schemaValidate('http://www.w3.org/TR/xmldsig-core/xmldsig-core-schema.xsd');
?>

Expected result:
----------------
method must return false, excution must be continued.

Actual result:
--------------
[pisman@nothing]~/testsys]php ff.php 
zsh: segmentation fault (core dumped)  php ff.php


bt outpuut is seems like infinite recursion.




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-11-07 13:42 UTC] rrichards@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

not PHP issue bug in libxml schema error handling
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Dec 04 03:01:23 2020 UTC