|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35107 compile failure with PHP 5.1 + MySQL 5
Submitted: 2005-11-04 17:40 UTC Modified: 2005-11-07 15:35 UTC
From: alex at whitewhale dot net Assigned: wez (profile)
Status: Closed Package: PDO related
PHP Version: 5CVS-2005-11-05 (snap) OS: MacOS X 10.4.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
32 - 8 = ?
Subscribe to this entry?

 [2005-11-04 17:40 UTC] alex at whitewhale dot net
Not very knowledgeable about compiler issues, but: getting a 
compile failure on MacOS X related to MySQL. PHP 5.1 RC3 
compiled with MySQL 5 successfully, but RC4 and a snapshot 
from this morning both fail using the following configure 

./configure --with-apxs=/usr/sbin/apxs --prefix=/usr --enable-
inline-optimization --with-libxml-dir=/sw --with-mysqli=/usr/
local/mysql/bin/mysql_config --with-gd --with-jpeg-dir=/sw --
with-png-dir=/sw --with-zlib-dir=/usr --with-pdo-mysql --with-
xmlrpc --with-mm=/usr/local --disable-debug --with-ldap --

Reproduce code:

Expected result:
a successful compile

Actual result:
/usr/bin/ld: warning multiple definitions of symbol _regcomp
/usr/sbin/httpd definition of _regcomp
(regcomp.So) definition of _regcomp
/usr/bin/ld: warning multiple definitions of symbol _regexec
/usr/sbin/httpd definition of _regexec
(regexec.So) definition of _regexec
/usr/bin/ld: warning multiple definitions of symbol _regfree
/usr/sbin/httpd definition of _regfree
(regfree.So) definition of _regfree
/usr/bin/ld: Undefined symbols:
collect2: ld returned 1 exit status
make: *** [libs/libphp5.bundle] Error 1


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2005-11-04 18:20 UTC]
Does this configure line work any better:

# rm config.cache
# ./configure --disable-all --with-apxs=/usr/sbin/apxs \

 [2005-11-05 02:17 UTC] alex at whitewhale dot net
Actually, I ran "make clean" several times in trying to 
diagnose this. Also, as I said, I tried compiling a fresh 
snapshot this morning to no avail.

I was finally able to compile it with your suggested, 
stripped-down config line after both "rm config.cache" and 
"make clean" but the moment I tried it with my normal config 
line, it failed again with the original error.

Just to be clear, the following sequence does *not* work for 
me (on my Mac, it works on my Linux box):

rm config.cache
make clean
./configure --with-apxs=/usr/sbin/apxs --prefix=/usr --
enable-inline-optimization --with-libxml-dir=/sw --with-
mysqli=/usr/local/mysql/bin/mysql_config --with-gd --with-
jpeg-dir=/sw --with-png-dir=/sw --with-zlib-dir=/usr --with-
pdo-mysql --with-xmlrpc --with-mm=/usr/local --disable-debug 
--with-ldap --enable-soap
 [2005-11-05 12:39 UTC]
So now we've found out that the problem isn't in ext/mysqli.
Try this configure line (with the usual "rm config.cache" and "make clean", which are only needed if you're not using fresh sources everytime)

# ./configure --disable-all --enable-pdo --with-pdo-mysql
 [2005-11-05 16:38 UTC]
Assigned to the PDO maintainer.
 [2005-11-05 17:20 UTC]
Please try using this CVS snapshot:
For Windows:

I just committed a fix; please try the next snapshot.
 [2005-11-05 22:59 UTC] alex at whitewhale dot net
Okay, tried the following with latest snapshot:

rm config.cache
./configure --with-apxs=/usr/sbin/apxs --prefix=/usr --with-
mysqli=/usr/local/mysql/bin/mysql_config --with-zlib --with-

It fails to run with:

checking for MySQL support for PDO... yes
checking for mysql_config... not found
configure: error: Cannot find MySQL header files under 

I have verified that /usr/local/mysql/bin/mysql_config is 
there and mysql.h is in /usr/local/mysql/include. This was a 
standard MySQL 5.0.15 install with the MacOS X installer.

If I use the same configure line without --with-pdo-mysql it 
finishes configure successfully.
 [2005-11-07 15:33 UTC]
What does it say in config.log? (if anything, don't paste the whole file, only 5 last lines MAX!)

 [2005-11-07 15:35 UTC]
Actually, it will work if you pass the configure option correctly, just like with --with-mysqli.

PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed May 18 09:04:05 2022 UTC