php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #35094 Thread support for CLI
Submitted: 2005-11-03 22:05 UTC Modified: 2010-06-08 09:11 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: testic at testic dot demon dot co dot uk Assigned:
Status: Duplicate Package: *General Issues
PHP Version: 5.0.5 OS: Win32 / Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: testic at testic dot demon dot co dot uk
New email:
PHP Version: OS:

 

 [2005-11-03 22:05 UTC] testic at testic dot demon dot co dot uk
Description:
------------
I would like to request thread support for CLI versions of PHP for all platforms.

I would like to develop applications that use GTK, and are able to multi-task. I have found this incredibly difficult without having access to threads.

I am aware that one has access to forking, but this isn't really suitable, not least because the functions are not available under Win32


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-06-08 09:11 UTC] aharvey@php.net
-Status: Open +Status: Duplicate -Package: Feature/Change Request +Package: *General Issues
 [2010-06-08 09:11 UTC] aharvey@php.net
Closing in favour of bug #46919.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC