php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35083 Many notice messages in PHPWiki, but I've supressed them
Submitted: 2005-11-03 11:20 UTC Modified: 2005-11-03 11:29 UTC
From: bt at diamos dot de Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.4.1 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bt at diamos dot de
New email:
PHP Version: OS:

 

 [2005-11-03 11:20 UTC] bt at diamos dot de
Description:
------------
Recently I've upgraded from v4.3.11 to v4.4.1 and in our PHPWiki I've noticed my Notice messages like this:

PHP Warnings

lib/WikiUser.php:50: Notice[8]: Only variables should be assigned by reference

lib/pear/DB/common.php:741: Notice[8]: Only variable references should be returned by reference

lib/pear/DB/common.php:741: Notice[8]: Only variable references should be returned by reference

lib/pear/DB/common.php:741: Notice[8]: Only variable references should be returned by reference

lib/pear/DB/common.php:741: Notice[8]: Only variable references should be returned by reference

lib/pear/DB/common.php:741: Notice[8]: Only variable references should be returned by reference

lib/Template.php:220: Notice[8]: Only variables should be assigned by reference

lib/Template.php:106: Notice[8]: Only variables should be assigned by reference

lib/Template.php:107: Notice[8]: Only variables should be assigned by reference

But my configuration in php.ini should supress this messages , I'm using this config:

error_reporting  = E_ALL & ~E_NOTICE
display_errors = Off
display_startup_errors = Off
ignore_repeated_errors = On

A downgrade to v4.3.11 removed the Notice messages


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-11-03 11:29 UTC] derick@php.net
Please contact the PHPWiki developers to resolve this, this is not a bug in PHP.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Oct 01 21:05:52 2022 UTC