php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35081 using the example for .NET causes a com_exeption
Submitted: 2005-11-03 08:03 UTC Modified: 2006-02-04 12:06 UTC
Votes:5
Avg. Score:4.6 ± 0.5
Reproduced:5 of 5 (100.0%)
Same Version:5 (100.0%)
Same OS:4 (80.0%)
From: mcyra at chello dot at Assigned: wez (profile)
Status: Not a bug Package: COM related
PHP Version: 5CVS-2005-11-03 (snap) OS: WinXP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mcyra at chello dot at
New email:
PHP Version: OS:

 

 [2005-11-03 08:03 UTC] mcyra at chello dot at
Description:
------------
A sample script from documentation causes this error.
German version of WinXP.
Microsoft .NET Framework 1.1.
Microsoft .NET Framework 1.1 German Language Pack.
PHP 5.0.5 (cli) (build: Sep 5 2005 15:54:44)
Zend Engine v2.0.5

Reproduce code:
---------------
<?php
  $stack = new DOTNET("mscorlib", "System.Collections.Stack");

  $stack->Push(".Net");
  $stack->Push("Hello ");

  echo $stack->Pop() . $stack->Pop();
?>

Actual result:
--------------
Fatal error: Uncaught exception 'com_exception' with message 'Failed to instantiate .Net object [CreateInstance] [0x80070057] Falscher Parameter.' in D:\NET\test.php:2
Stack trace: 
#0 D:\NET\test.php(2): dotnet->dotnet('mscorlib', 'System.Collecti...')
#1 {main}
  thrown in D:\NET\test.php on line 2

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-11-03 15:47 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip


 [2005-11-03 18:13 UTC] mcyra at chello dot at
I have checked with the given link, result was:

Fatal error: Uncaught exception 'com_exception' with message 'Failed to instantiate .Net object [CreateInstance] [0x80070057] Falscher Parameter.' in D:\NET\test.php:2
Stack trace:
#0 D:\NET\test.php(2): dotnet->dotnet('mscorlib', 'System.Co
llecti...')
#1 {main}
  thrown in D:\NET\test.php on line 2
 [2005-11-03 22:13 UTC] sniper@php.net
Assigned to the maintainer of COM extension.
 [2005-12-07 21:03 UTC] jamie dot layne at gmail dot com
I am experiencing the same problem as well.

Summary:
--------
.NET:  Microsoft .NET Framework 1.1
OS: Windows Server 2003 Standard Edition SP1
PHP:  PHP 5.0.5 (cli) (built: Sep  5 2005 15:54:44)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v2.0.5, Copyright (c) 1998-2004 Zend Technologies

Code Sample:
-------------

<?PHP
  $stack = new DOTNET("mscorlib", "System.Collections.Stack"); 
  $stack->Push(".Net"); 
  $stack->Push("Hello "); 
  echo $stack->Pop() . $stack->Pop(); 
?>

Actual Result:
--------------
Fatal error: Uncaught exception 'com_exception' with message 'Failed to instantiate .Net object [CreateInstance] [0x80070057] The parameter is incorrect. ' in C:\DOTNET\sample.php:2 Stack trace: #0 C:\DOTNET\sample.php(2): dotnet->dotnet('mscorlib', 'System.Collecti...') #1 {main} thrown in C:\DOTNET\sample.php on line 2
 [2006-02-04 12:06 UTC] rrichards@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

dupe of bug #33188
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 08 06:05:52 2022 UTC