|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35026 fwrite to socket stream no longer working as expected
Submitted: 2005-10-30 18:07 UTC Modified: 2005-10-30 19:09 UTC
From: lists at cyberlot dot net Assigned:
Status: Closed Package: Network related
PHP Version: 5.1.0RC4 OS: Fedora Core 3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: lists at cyberlot dot net
New email:
PHP Version: OS:


 [2005-10-30 18:07 UTC] lists at cyberlot dot net
I have tried running both the socket server and the socket test script on multiple versions found the only part that matters is what version the server is running on.

On RC1 it works fine, RC3 and RC4 ( never tried RC2 ) some of the writes get "lost"

Reproduce code:

Run the engine.php in one terminal, runtests.php in other.. RC1 everything works RC3 and RC4 the tests never finish, Mine always hang on the 3rd test.

I haven't been able to reproduce with a simpler set of code as of yet.

Expected result:
Tests to be completed

Actual result:
Tests fail


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2005-10-30 18:19 UTC]
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc.

If possible, make the script source available online and provide
an URL to it here. Try to avoid embedding huge scripts into the report.

A SHORT reproduce script is required 10-20 lines.
 [2005-10-30 19:09 UTC] lists at cyberlot dot net
I am sorry, I assumed this to be a socket issue when in reality it turned out to be a simple_xml issue

It is possible for a simpleXMLElemnt Object to fail a 
if($object) {


Test in RC3 and RC4 will resubmit as new bug
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jan 18 17:03:14 2022 UTC