php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3489 Fatal error: Failed opening required file in PHP script
Submitted: 2000-02-15 21:43 UTC Modified: 2002-10-01 14:32 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: d dot tilloy at nnx dot com Assigned:
Status: Wont fix Package: Parser error
PHP Version: 3.0.14 or 3.0.15 OS: Linux/2.2.x/ PHP-3.0.14+ / Apach
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: d dot tilloy at nnx dot com
New email:
PHP Version: OS:

 

 [2000-02-15 21:43 UTC] d dot tilloy at nnx dot com
When using PHP-3.0.14 with Apache-1.3.11, include directive or
require directive randomly fail opening required file.

Exact error message is :
--- 8< ---
Fatal error: Failed opening required 'foo2.php' in
/path/to/bugphp/foo.phtml on line 2
--- 8< ---

	Content of this file is like this :

$ cat foo.phtml
<?
require ("foo2.php");
echo "foo";
?>

$ cat foo2.php
<?
echo "<br>FROM FOO2<BR>
?>

	The problem is the same with or without using 
include_path (php3.ini, httpd.conf or .htaccess).

The only way to prevent this error is call include or require with the
full path of your file. Another potential way is to prefix file by ./ like :
require ("./foo2.php");

	This problem seems to appear only on some virtualhosts, and
not another. Using .htaccess with php3_* directives seems to produce
this bug more without .htaccess.

Bug is a non reproductible crash, because this error appears randomly
(1 to 100 request, or more requests for another users of the internet).

Apache does not seems to be affected, because this problem appears
again with Apache_1.3.9, and seems to not appears with PHP-3.0.12.
--
David TILLOY - Chef de projets - <d.tilloy@nnx.com>
Neuronnexion (nnx) - 19/21, rue des Augustins - F-80000 Amiens

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-03-08 13:27 UTC] d dot tilloy at nnx dot com
this error is appear too with PHP-3.0.15.
I have the same bug on some plateform, with
different configurations. Just downgrad to PHP-3.0.13
fix this bug (but it's not usefull ;( )

--
David TILLOY - Chef de projets - <d.tilloy@nnx.com>
Neuronnexion (nnx) - 19/21, rue des Augustins - F-80000 Amiens
 [2002-10-01 14:32 UTC] hholzgra@php.net
We are sorry, but can not support PHP 3 related problems anymore.
Momentum is gathering for PHP 5, and we think supporting PHP 3 will
lead to a waste of resources which we want to put into getting PHP 5
ready. Ofcourse PHP 4 will will continue to be supported for the
forseeable future.

most likely '.' not in include path?
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jun 27 08:01:40 2019 UTC