php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34613 complexType is not recognized correctly
Submitted: 2005-09-23 13:54 UTC Modified: 2005-09-23 15:01 UTC
From: moritz dot augustin at core-networks dot de Assigned:
Status: Not a bug Package: SOAP related
PHP Version: 6CVS-2005-09-23 (CVS) OS: Linux 2.6.12.4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: moritz dot augustin at core-networks dot de
New email:
PHP Version: OS:

 

 [2005-09-23 13:54 UTC] moritz dot augustin at core-networks dot de
Description:
------------
I try to access a not-PHP web service (SOAP, WSDL available) using ext/soap.
But my parameters aren't put correctly in the xml request. What am I doing wrong?

The PHP documentation is not complete at this point, so it's undocumentated.

My question: What's the general syntax for nestled parameters (or: how must the following $parameters be built?). 

Best Regards,
Moritz Augustin
Core Networks GmbH - http://www.core-networks.de

Reproduce code:
---------------
Relevant content of WSDL (some parts are replaced by an asterisk): http://dev.unitedservers.de/moritz/wsdl

// the constructor array argument just sets the real class variables
$client = new SoapClient(*****, array ("trace" => 1, "classmap" => array (
	"GetModifiedOrdersInput"	=> "GetModifiedOrdersInput",
	"QueryRequestHeader"		=> "QueryRequestHeader",
	"orderQueryOptions"			=> "orderQueryOptions"
)));

$parameters = new GetModifiedOrdersInput (array (
		"QueryRequestHeader"	=> new QueryRequestHeader (array (
			"PartnerCode"			=> "XXXXXXXXX",
			"ReplayToken"			=> "aaaaaaaaaa8sdmf23n4asdkjHAsd8123"
		)),
		"FromDate"				=> time () - 3600 * 24 * 30,
		"ToDate"				=> time (),
		"orderQueryOptions"		=> new orderQueryOptions (array (
		
		))
	));

try {
$client->GetModifiedOrders ($parameters); }
catch (SoapFault $f) {
echo $f->faultstring; echo $f->faultcode; }

echo htmlspecialchars ($client->__getLastRequest ());

Expected result:
----------------
No errors.
A xml file with the contents of $parameters.

Actual result:
--------------
An error message without useful information:
        null
      fc:JWSError

And the xml file without any useful data:
<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://api.geotrust.com/webtrust/query"><SOAP-ENV:Body><ns1:GetModifiedOrders/></SOAP-ENV:Body></SOAP-ENV:Envelope>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-23 15:01 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC