php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34595 ftp_ssl_connect is not workin even after enabling php_openssl.dll extension
Submitted: 2005-09-22 12:41 UTC Modified: 2005-09-23 06:08 UTC
From: mittalsumit at netscape dot net Assigned:
Status: Not a bug Package: FTP related
PHP Version: 5.0.5 OS: Windows XP Professional
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mittalsumit at netscape dot net
New email:
PHP Version: OS:

 

 [2005-09-22 12:41 UTC] mittalsumit at netscape dot net
Description:
------------
hi i wanted to run ftp_ssl_connect function but it says undefined. I tried to compile php from source it has a lot of errors and did not get compiled. in my phpinfo it shows ftps is enabled after doing php_openssl.dll uncommented in php.ini. A quick response will be highly appricieated.


;extension=php_oci8.dll
extension=php_openssl.dll
;extension=php_oracle.dll

Expected result:
----------------
function should work

Actual result:
--------------
Fatal error: Call to undefined function ftp_ssl_connect() in C:\php5\getm.php on

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-22 13:24 UTC] sniper@php.net
RTFM: "Why this function may not exist:  ftp_ssl_connect() is only available if OpenSSL support is enabled into your version of PHP. If it's undefined and you've compiled FTP support then this is why. For Windows you must compile your own PHP binaries to support this function."

 [2005-09-22 17:06 UTC] mittalsumit at netscape dot net
I think that is basic thing which any body can read on.. But the problem is i am doing extension=php_openssl.dll in php.ini and system is showing output of phpinfo function as 

Registered PHP Streams => php, file, http, ftp, compress.zlib, https, ftps  
Registered Stream Socket Transports => tcp, udp, ssl, sslv3, sslv2, tls

Then why this function is not working. In case if still it won't work then must be a bug. Or in case I have to compile then what is best way to do it.
 [2005-09-22 19:22 UTC] wez@php.net
It's not working because openssl is not *statically* compiled into PHP in our Windows snapshot builds.

 [2005-09-23 06:08 UTC] mittalsumit at netscape dot net
I have got few docs telling the php compilation on windows as well read the php manual for the same but all give error while compiling it.. is there any link where i can find a good document which tell how to compile it for windows with *ssl statically* a quick response will be highly appiciated
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed May 25 07:05:45 2022 UTC