php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34404 Module sapi_apache2 not included
Submitted: 2005-09-07 12:41 UTC Modified: 2005-09-07 12:50 UTC
From: ericvanblokland at gmail dot com Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 5.0.4 OS: Fedora Core X
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ericvanblokland at gmail dot com
New email:
PHP Version: OS:

 

 [2005-09-07 12:41 UTC] ericvanblokland at gmail dot com
Description:
------------
We've got several php5 configurations running. Some of them compiled manually, others installed from rpm. None of them include the sapi_apache2 module.

We're trying to start some php5 virtual hosting, but without sapi_apache2 we are unable to change any php_admin_value

Reproduce code:
---------------
Just run a script with 
<?php 
phpinfo();
?>

You may also add some php_admin_value in your httpd.conf, they will not be applied and cause an error when outside as <IfModule sapi_apache2.c></IfModule> block

Expected result:
----------------
sapi_apache2 listed at apache2handler loaded modules

and/or php_admin_value applied

Actual result:
--------------
sapi_apache2 is not listed at apache2handler loaded modules

php_admin_value not applied

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-07 12:50 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Works fine when done right.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Feb 28 13:01:27 2024 UTC