php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34375 It is trouble in "mb_convert_encoding" function.
Submitted: 2005-09-05 13:03 UTC Modified: 2005-09-07 13:52 UTC
From: tomohiro at jk dot jip dot co dot jp Assigned:
Status: Closed Package: mbstring related
PHP Version: 4.4.0 OS: Solaris 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tomohiro at jk dot jip dot co dot jp
New email:
PHP Version: OS:

 

 [2005-09-05 13:03 UTC] tomohiro at jk dot jip dot co dot jp
Description:
------------
It is trouble in "mb_convert_encoding" function.
"mb_convert_encoding($message, 'JIS', 'auto');" is failed.
"mb_convert_encoding($message, 'JIS', 'EUC-JP');" is not trouble. 

In php.ini, "mbstring.detect_order" is not set. 
";mbstring.detect_order = auto"

It is unquestionable in php-4.3.10.


Reproduce code:
---------------
<?php
$message = "??";
$message = mb_convert_encoding($message, 'JIS', 'auto');
print ($message);
?>

Expected result:
----------------
??

Actual result:
--------------
?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-05 18:27 UTC] sniper@php.net
> It is unquestionable in php-4.3.10.

You mean it worked in PHP 4.3.10 or what?

 [2005-09-07 13:52 UTC] tomohiro at jk dot jip dot co dot jp
I'm sorry. I misunderstood it.
The problem was solved.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Oct 07 21:03:44 2022 UTC