php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34343 Huge memory leaks in ISAPI
Submitted: 2005-09-02 12:28 UTC Modified: 2005-09-02 16:15 UTC
From: jakub at icewarp dot com Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.4.0 OS: Any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jakub at icewarp dot com
New email:
PHP Version: OS:

 

 [2005-09-02 12:28 UTC] jakub at icewarp dot com
Description:
------------
Since PHP 3.0 there is a huge memory leak in the ISAPI module. Probably it is inside of the PHP core itself.
It is very easy to reproduce it. A simple

<?
  phpinfo();
?>

code leaks about 28MB after 200 calls.

Please, somebody fix it. Take your precious time, create an ISAPI extension call to PHP ISAPI DLLm pass it info.html and loop it 200 times and find the memory leak...

From what I saw PHP 4.4.0 is faster than previous versions but seem to leak more.

I'm willing to help anyway I can. Thank you


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-02 16:15 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Tue Mar 21 18:03:39 2023 UTC