php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34327 Antivirus Detection and Delettion of Virus Infected Files
Submitted: 2005-09-01 13:15 UTC Modified: 2005-09-01 13:19 UTC
From: thebomani at hotmail dot com Assigned:
Status: Not a bug Package: *Directory/Filesystem functions
PHP Version: 5.0.4 OS: Red Hat Fedora 3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
27 - 13 = ?
Subscribe to this entry?

 
 [2005-09-01 13:15 UTC] thebomani at hotmail dot com
Description:
------------
I am writting because I am working on a script that uses CLAMAV to scan uploaded files for viruses. I have noticed that when I upload a file that is infected with test virus such a "eicar.com.txt" the file gets deleted even if I rename or move the file or get a chance to scan it for viruses. If PHP is deleting the file is there any way to stop the file from being deleted or output the reason why the file was deleted.

Reproduce code:
---------------
<?

chmod ("$img", 0775);

$tmp_file = "/tmp/". md5(uniqid(rand(), true));

rename("$img", $tmp_file);



$clamscan_prog = "/usr/local/bin/clamscan";

$data_input = "-v --stdout $tmp_file";

$data_size = strlen("$data_input");



$scan_result = passthru("$clamscan_prog $data_input");

//unlink("$img");

die("$tmp_file <br> $scan_result");

?>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-01 13:19 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Oct 05 09:05:52 2022 UTC