php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34294 Bug in casting a float to integer
Submitted: 2005-08-29 13:35 UTC Modified: 2005-09-22 21:37 UTC
From: moerel at gmail dot com Assigned:
Status: Not a bug Package: Math related
PHP Version: 5.0.4 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: moerel at gmail dot com
New email:
PHP Version: OS:

 

 [2005-08-29 13:35 UTC] moerel at gmail dot com
Description:
------------
I found some strange behaviour while casting a float to integer. It looks like something gets rounded in a strange way while casting.



Reproduce code:
---------------
<?
	$fltTest = 9.95;

	print ($fltTest * 100) . '<BR>';
	print round($fltTest * 100) . '<BR>';
	print (int)($fltTest * 100) . '<BR>';
?>


Expected result:
----------------
995
995
995


Actual result:
--------------
995
995
994


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-08-29 13:41 UTC] sniper@php.net
Floating point values have a limited precision. Hence a value might 
not have the same string representation after any processing. That also
includes writing a floating point value in your script and directly 
printing it without any mathematical operations.

If you would like to know more about "floats" and what IEEE
754 is read this:
http://docs.sun.com/source/806-3568/ncg_goldberg.html
 
Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Apr 01 22:01:23 2020 UTC