php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34213 if a file exists , mkdir() can't creat a folder as same name
Submitted: 2005-08-22 21:47 UTC Modified: 2005-08-22 22:03 UTC
From: js1 at qq dot com Assigned:
Status: Not a bug Package: Directory function related
PHP Version: 5.0.4 OS: windows2003+IIS6
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: js1 at qq dot com
New email:
PHP Version: OS:

 

 [2005-08-22 21:47 UTC] js1 at qq dot com
Description:
------------
file "D:/web/test1" exists,can`t creat a folder "D:/web/test1/"

Reproduce code:
---------------
<?
mkdir("D:/web/test1/");
?>

Expected result:
----------------
creat a folder "D:/web/test1/"


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-08-22 22:03 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

That\'s your operating system preventing this!
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Aug 12 00:03:34 2022 UTC