|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34204 Apache2s mod_rewrite does not work with PHP5.1.0RC1
Submitted: 2005-08-21 12:55 UTC Modified: 2005-11-25 11:40 UTC
From: arpad at zooloo dot com Assigned:
Status: Closed Package: Apache2 related
PHP Version: 5CVS-2005-11-10 (snap) OS: Windows XP SP1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: arpad at zooloo dot com
New email:
PHP Version: OS:


 [2005-08-21 12:55 UTC] arpad at zooloo dot com
With PHP5.1.0RC1 my Apache2 mod_rewrite crashes everytime i want to use it. It worked fine with PHP5.1.0b3 though.

Reproduce code:
RewriteEngine on

RewriteRule index.html index.php

Expected result:
it should display index.html as it was index.php

Actual result:
Server crashes with the following log entry:
[notice] Parent: child process exited with status 3221225477 -- Restarting.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2005-11-01 11:26 UTC]
Latest CVS checkout of PHP_5_1 branch works fine.

 [2005-11-13 12:02 UTC] arpad at zooloo dot com
I just tried the php5.1-win32-200511102330 Snapshot and it does still not work.
 [2005-11-14 20:43 UTC]
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2005-11-22 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2005-11-25 11:40 UTC] arpad at zooloo dot com
Tried 5.1.0 final and it finally works again.
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Dec 06 17:05:53 2022 UTC