php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3414 Transparent session quirk
Submitted: 2000-02-05 20:46 UTC Modified: 2000-08-01 09:31 UTC
From: moenm at hotmail dot com Assigned: hholzgra (profile)
Status: Closed Package: Session related
PHP Version: 4.0 Latest CVS (05/02/2000) OS: RedHat 6.1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: moenm at hotmail dot com
New email:
PHP Version: OS:

 

 [2000-02-05 20:46 UTC] moenm at hotmail dot com
I found that when using CSS and the transparent sessions that you can not put the class tag before the href. I wasn't sure if this was what was intended, I don't recall seeing it documented. See below

This one:
<a href="someLink.php" class="someClass"> 
will track the session.

This one:
<a class="someClass" href="someLink.php">
does not.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-02-16 18:26 UTC] sas at cvs dot php dot net
Correct behaviour (as in it's implemented that way), currently undocumented.
 [2000-07-25 21:08 UTC] zak@php.net
Changing type to 'Session related'
 [2000-07-28 17:54 UTC] hholzgra@php.net
rewrite is gonna happen ... 
 [2000-08-01 09:31 UTC] hholzgra@php.net
latest cvs should get it right
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Sep 29 07:05:53 2022 UTC