php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34084 RecursiveFilterIterator causes fatal error
Submitted: 2005-08-11 19:59 UTC Modified: 2005-08-11 22:40 UTC
From: bjori@php.net Assigned: helly (profile)
Status: Closed Package: SPL related
PHP Version: 5CVS-2005-08-11 (dev) OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bjori@php.net
New email:
PHP Version: OS:

 

 [2005-08-11 19:59 UTC] bjori@php.net
Description:
------------
Class RecursiveFilterIterator contains 1 abstract method and must therefore be declared abstract or implement the remaining methods...

Reproduce code:
---------------
php -v


Expected result:
----------------
PHP 6.0.0-dev (cli) (built: Aug 11 2005 04:38:23) (DEBUG)
Copyright (c) 1997-2005 The PHP Group
Zend Engine v2.1.0-dev, Copyright (c) 1998-2005 Zend Technologies


Actual result:
--------------
PHP Fatal error:  Class RecursiveFilterIterator contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (FilterIterator::accept) in Unknown on line 0
<br />
<b>Fatal error</b>:  Class RecursiveFilterIterator contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (FilterIterator::accept) in <b>Unknown</b> on line <b>0</b><br />
PHP 6.0.0-dev (cli) (built: Aug 11 2005 04:38:23) (DEBUG)
Copyright (c) 1997-2005 The PHP Group
Zend Engine v2.1.0-dev, Copyright (c) 1998-2005 Zend Technologies


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-08-11 20:28 UTC] tony2001@php.net
Works fine here.
Try it with clean checkout.

 [2005-08-11 20:53 UTC] bjori@php.net
$ cvs -d :pserver:cvsread@cvs.php.net:/repository checkout php-src
$ cd php-src/
$ ./buildconf --force
$ ./configure --with-zend-vm=GOTO --enable-debug --with-apxs2=/usr/local/sbin/apxs --prefix=/usr/home/dev
$ make
$ ./sapi/cli/php -v
PHP Fatal error:  Class RecursiveFilterIterator contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (FilterIterator::accept) in Unknown on line 0
<br />
<b>Fatal error</b>:  Class RecursiveFilterIterator contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (FilterIterator::accept) in <b>Unknown</b> on line <b>0</b><br />
PHP 6.0.0-dev (cli) (built: Aug 11 2005 20:55:00) (DEBUG)
Copyright (c) 1997-2005 The PHP Group
Zend Engine v2.1.0-dev, Copyright (c) 1998-2005 Zend Technologies
 [2005-08-11 21:09 UTC] tony2001@php.net
Aha, so actually the problem was with my checkout =)
Marcus, fix your last patch, please.
 [2005-08-11 22:11 UTC] helly@php.net
I cannot reproduce. And i had the exact same behavior before i fixed the engine. So please be sure to cvs up your engine. At least zend_compile.c needs to be updated.
 [2005-08-11 22:40 UTC] helly@php.net
cvs ci for zend was blocked.
 [2005-08-11 22:40 UTC] helly@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC