php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34082 Mailing list servers mangle SMTP headers
Submitted: 2005-08-11 16:41 UTC Modified: 2013-12-13 07:38 UTC
Votes:3
Avg. Score:4.3 ± 0.9
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: nohn@php.net Assigned: wez (profile)
Status: Closed Package: Systems problem
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: nohn@php.net
New email:
PHP Version: OS:

 

 [2005-08-11 16:41 UTC] nohn@php.net
Description:
------------
Mailing list servers mangle headers. There is no way to track down spammers this way.

Expected result:
----------------
Full headers

Actual result:
--------------
Received: by mail.nohn.net (Postfix, from userid 1010)
	id E49F637C125; Thu, 11 Aug 2005 12:06:16 +0200 (CEST)
Received: from lists.php.net (lists.php.net [216.92.131.4])
	by mail.nohn.net (Postfix) with ESMTP id 8ABE237C120
	for <lists-sebastian@nohn.net>; Thu, 11 Aug 2005 12:06:09 +0200 (CEST)
X-Host-Fingerprint: 216.92.131.4 lists.php.net  
Received: from ([216.92.131.4:9466] helo=lists.php.net)
	by pb1.pair.com (ecelerity 2.0 beta r(6323M)) with SMTP
	id 42/E3-24081-E032BF24 for <lists-sebastian@nohn.net>; Thu, 11 Aug 2005 06:06:06 -0400
Received: (qmail 85266 invoked by uid 1010); 11 Aug 2005 10:05:46 -0000
Mailing-List: contact pear-dev-help@lists.php.net; run by ezmlm

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-08-11 16:44 UTC] wez@php.net
Suspending until someone divines how to persuade ezmlm to do this.  It seems to be a feature.

 [2005-08-11 17:09 UTC] nohn@php.net
http://www.ezmlm.org/faq/FAQ-6.html#ss6.2

Would you mind reporting a bug/feature request?
 [2005-08-11 17:14 UTC] wez@php.net
I think you're quite capable of doing that yourself.

 [2005-08-11 17:42 UTC] nohn@php.net
"Describe the error, your setup, and your system in sufficient detail so that it can be reproduced by third parties."

I don't know the setup. And I don't know if you just did not find how to change that behaviour.
 [2006-04-23 08:41 UTC] nohn@php.net
Please try if it works this way:

http://www.ezmlm.org/ezman/ezman3.html#ss3.7

Removing certain headers from messages.

DIR/headerremove contains headers that are removed from all messages before they are sent to the subscribers. Some of these must be removed in order for the list to function. You can add others (see More information). If you add a header that should not occur multiple times, it is good to add the same header here to have it removed from incoming messages, if it exists. 
 [2006-04-23 15:36 UTC] wez@php.net
I don't see any way to preserve the received headers, so I added a header like:

X-PHP-List-Original-Sender: wez@thebrainroom.com

for mail that enters the box from the outside world.
 [2013-12-13 07:38 UTC] wez@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Apr 19 15:01:23 2021 UTC