php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #33951 ext/dom: warning with urlencoded() information, that should be unformatted
Submitted: 2005-08-01 20:25 UTC Modified: 2020-04-07 13:55 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: r dot korving at xit dot nl Assigned: cmb (profile)
Status: Closed Package: DOM XML related
PHP Version: 5.0.4 OS: Debian GNU/Linux (Sarge) 2.4.26
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
39 + 48 = ?
Subscribe to this entry?

 
 [2005-08-01 20:25 UTC] r dot korving at xit dot nl
Description:
------------
DOMDocument::schemaValidate throws three(!) warnings when the XSD-file does not exist. I think one warning would do. The low-level I/O warning it shows should be supressed (e.g. file_get_contents() doesn't show this warning either). If the low-level I/O warning should remain, it could be fixed, because right now it urlencodes the information it spits out, while it shouldn't.

Reproduce code:
---------------
<?
  $doc = new DOMDocument();

  $doc->schemaValidate("/non existant file.xsd");
?>

Expected result:
----------------
Warning: xmlSchemaParse: could not load '/non existant file.xsd'. in /www/admin/dev/bugreports/dom-validate/index.php on line 4

Actual result:
--------------
Warning: I/O warning : failed to load external entity "/non%20existant%20file.xsd" in /www/admin/dev/bugreports/dom-validate/index.php on line 4

Warning: xmlSchemaParse: could not load '/non existant file.xsd'. in /www/admin/dev/bugreports/dom-validate/index.php on line 4

Warning: Invalid Schema in /www/admin/dev/bugreports/dom-validate/index.php on line 4

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-04-08 21:47 UTC] jani@php.net
-Package: Feature/Change Request +Package: DOM XML related
 [2020-04-07 13:55 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2020-04-07 13:55 UTC] cmb@php.net
> DOMDocument::schemaValidate throws three(!) warnings when the
> XSD-file does not exist. I think one warning would do.

Then call libxml_use_internal_errors(true). :)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Apr 10 14:01:25 2020 UTC