php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33896 limited replacement parameter on ereg_replace function
Submitted: 2005-07-28 00:39 UTC Modified: 2005-07-28 10:06 UTC
From: wfernandom2004 at yahoo dot com dot br Assigned:
Status: Not a bug Package: Regexps related
PHP Version: 4.4.0 OS: Linux, Ubuntu
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: wfernandom2004 at yahoo dot com dot br
New email:
PHP Version: OS:

 

 [2005-07-28 00:39 UTC] wfernandom2004 at yahoo dot com dot br
Description:
------------
It is impossible put in the replacement parameter, on ereg_replace function, one literal text of this format: \digit, e.g, \1, because the substrings replacements have preference.

It, for me, is interesting when preparing string substituitions previously, with the ereg_replace function.

Reproduce code:
---------------
echo ereg_replace("a", "\\\\0", "bbabb");

Expected result:
----------------
bb\0bb

Actual result:
--------------
bbabb

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-07-28 10:06 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 19 19:04:05 2022 UTC