php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33765 SOAP one-way is not fire-and-forget
Submitted: 2005-07-19 09:20 UTC Modified: 2005-10-11 18:01 UTC
Votes:5
Avg. Score:4.4 ± 0.8
Reproduced:5 of 5 (100.0%)
Same Version:3 (60.0%)
Same OS:3 (60.0%)
From: php at sowen dot de Assigned: dmitry (profile)
Status: Wont fix Package: SOAP related
PHP Version: 5.1.0b3 OS: Gentoo Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: php at sowen dot de
New email:
PHP Version: OS:

 

 [2005-07-19 09:20 UTC] php at sowen dot de
Description:
------------
When I try to make a SOAP call to a server that doesn't reply with an answer, my client keeps on waiting until the server finished it's work. 

Shouldn't one-way operation be "fire-and-forget" in order to make more sense?

This could be solved by returning a HTTP 200 response and closing the socket, right after the SOAP call was received by the server.



Reproduce code:
---------------
Server code:
------------

public function onewaytest() {
   sleep(50);
}

Client code:
------------

$soap = new SoapClient(null, '...');
$starttime=time();
$soap->onewaytest();
echo time()-$starttime." sec\n";

Expected result:
----------------
Just the network time-overhead caused by HTTP connect and POST. 

Actual result:
--------------
Above 50 sec.

Patches

Add a Patch

Pull Requests

Add a Pull Request

 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC