php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33715 cant use php4 with memory-limit
Submitted: 2005-07-15 18:58 UTC Modified: 2005-07-16 22:17 UTC
From: excedor at gmail dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.4.0 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
5 + 24 = ?
Subscribe to this entry?

 
 [2005-07-15 18:58 UTC] excedor at gmail dot com
Description:
------------
When I try to run php4.4.0 with this configuration:

./configure --with-apxs2=/usr/local/httpd/bin/apxs --with-mysql --prefix=/usr/local/php4 --with-libxml-dir=/usr/lib --with-zlib --with-mysql=/usr/local/mysql --enable-soap --enable-sockets --with-gettext --enable-mbstring --with-gd --with-jpeg-dir=/usr/lib --enable-memory-limit




i get at SOME websites following message:

Bad Gateway

The proxy server received an invalid response from an upstream server.


Most of the sites are working - just one drupal version does not appear (i have the same drupalversion in different directories and the other are working, but they are not as complex and filled with content like the notworking version)

I didn't find the problem.

I know how to compile and to get it run, so that's not the problem.
When I run the same configuration without the enable-memory-limit parameter everything works perfectly (but i need memory_get_usage for some reasons, and it's only available with that parameter)

is it a bug or what could be the reason?

With php5 it's working but i would have to modify a LOT of things, so i would really prefer to use php4. 

Reproduce code:
---------------
./configure --with-apxs2=/usr/local/httpd/bin/apxs --with-mysql --prefix=/usr/local/php4 --with-libxml-dir=/usr/lib --with-zlib --with-mysql=/usr/local/mysql --enable-soap --enable-sockets --with-gettext --enable-mbstring --with-gd --with-jpeg-dir=/usr/lib --enable-memory-limit

Expected result:
----------------
The website...

http://www.humano2.org

Actual result:
--------------
Bad Gateway

The proxy server received an invalid response from an upstream server.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-07-16 22:17 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Configure your web-server properly.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Apr 16 23:01:30 2024 UTC