php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33706 $_POST bug
Submitted: 2005-07-14 21:03 UTC Modified: 2005-07-14 21:23 UTC
From: deucalion at lycos dot co dot uk Assigned:
Status: Not a bug Package: SOAP related
PHP Version: 5.0.4 OS: Windows2000,XP
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: deucalion at lycos dot co dot uk
New email:
PHP Version: OS:

 

 [2005-07-14 21:03 UTC] deucalion at lycos dot co dot uk
Description:
------------
$_post does not working in the SOAPclient. 

Reproduce code:
---------------
<html>
<body>
<? 
if (!$_POST['zipcode'])

 {

?>

<h2>U.S ZipCodesTemperatureService</h2>

<form action="<?=$_SERVER['PHP_SELF']?>" method="post">

Type search term: <input type="text" name="zipcode">

<input type="submit" name="submit" value="Invoke">

</form>

<?

} 

 else

{

$client = new soapclient("http://www.xmethods.net/sd/2001/DemoTemperatureService.wsdl",array (

"trace" => 1,

"exceptions" => 0)); 

$params= array ( "zipcode" => $_POST['zipcode'] );

$client->call("getTemp",$params");

print "<pre>\n"; 

print "Request :\n".htmlspecialchars($client->__getLastRequest()) ."\n";

print "Response:\n".htmlspecialchars($client->__getLastResponse())."\n";

print "</pre>";

}

?>

</body>

</html>



Expected result:
----------------
Request :
<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="urn:xmethods-Temperature-Demo" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><ns1:getTemp><zipcode xsi:type="xsd:string">zipcode</zipcode></ns1:getTemp></SOAP-ENV:Body></SOAP-ENV:Envelope>

Response:
<?xml version='1.0' encoding='UTF-8'?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<SOAP-ENV:Body>
<ns1:getTempResponse xmlns:ns1="urn:xmethods-Temperature-Demo" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
<return xsi:type="xsd:float">52.0</return>
</ns1:getTempResponse>

</SOAP-ENV:Body>
</SOAP-ENV:Envelope>



Actual result:
--------------
SERVER NOT FOUND. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-07-14 21:23 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Aug 19 13:05:44 2022 UTC