php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33704 similar to bug#19804
Submitted: 2005-07-14 20:05 UTC Modified: 2005-07-15 12:42 UTC
From: jokar30 at hotmail dot com Assigned:
Status: Not a bug Package: mcrypt related
PHP Version: 5.0.3 OS: sparc solaris 9
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jokar30 at hotmail dot com
New email:
PHP Version: OS:

 

 [2005-07-14 20:05 UTC] jokar30 at hotmail dot com
Description:
------------
Hello,

I have done nearly everything and I still get the supported ciphers and supported modes = none on the phpinfo(). 
I have set 
mcrypt.algorithms_dir = /opt/libmcrypt-2.5.6/modules/algorithms/
mcrypt.modes_dir = /opt/libmcrypt-2.5.6/modules/modes/
I have changed the chmod 755 to /usr/local/lib/libmcrypt 
I have cofigured php5.0.4 with ./configure' '--with-mcrypt=/opt/libmcrypt-2.5.6' '--with-mhash=/opt/php-5.0.4/ext/mhash' '--with-apxs=/usr/apache/bin/apxs' 

Any help would be appreciated ;-)

Thank you


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-07-14 21:27 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

And it doesn't make sense, as mcrypt now has all their modules builtin anyway so you don't need those directores. I guess you installed libmcrypt incorrectly.
 [2005-07-14 22:05 UTC] jokar30 at hotmail dot com
Thank you for your reply...
That means I should use mcrypt and not libmcrypt?

In this case, I should use ./configure'
'--with-mcrypt=/opt/mcrypt-x.y.z'
'--with-mhash=/opt/php-5.0.4/ext/mhash'
'--with-apxs=/usr/apache/bin/apxs' 
???
 [2005-07-15 12:42 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Mar 01 07:01:23 2021 UTC