php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33625 Trying to use SOAP Header with WSDL Crashes Apache & PHP
Submitted: 2005-07-09 20:41 UTC Modified: 2005-07-19 01:00 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: jplush76 at gmail dot com Assigned: george (profile)
Status: No Feedback Package: SOAP related
PHP Version: 5.0.4 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jplush76 at gmail dot com
New email:
PHP Version: OS:

 

 [2005-07-09 20:41 UTC] jplush76 at gmail dot com
Description:
------------
Brief Overview:
When trying to access a SOAP server via the php5 soap ext I'm getting crashes everytime I try to add soap headers to my script. If I leave out the wsdl things work ok however the desired behavior is to use the SOAP Headers with the wsdl file. (please note I'm not trying to use http authentication, this is for something that reads info off the header section)


if I make the wsdl parameter NULL and add the URL to my soap options array, everything works fine and my XML data that was posted to the server has my headers. However as I stated, using the wsdl file crashes EVERY time. 

Reproduce code:
---------------
http://www.litfuel.net/temp2/phpcrash.phps

SCREENSHOT
http://www.litfuel.net/temp2/crash.jpg



Expected result:
----------------
expected result should that the headers are included in the transaction properly and not crash anything. 

Actual result:
--------------
http://www.litfuel.net/temp2/crash.jpg

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-07-09 20:42 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip


 [2005-07-09 21:09 UTC] jplush76 at gmail dot com
my comments aren't showing up so I'll try here...

tried as you suggested with PHP Version 5.1.0-dev
got same result - crash
 [2005-07-09 21:14 UTC] tony2001@php.net
Assigned to the maintainer.
It would be very good if you try to reproduce it on *nix and get more than just a "picture". GDB backtrace would be very helpful. Thanks.
 [2005-07-09 21:25 UTC] jplush76 at gmail dot com
I don't have access currently to a nix system with PHP5x. 
I uploaded the mdmp file from the crash... not sure if that helps

http://www.litfuel.net/temp2/Apache.exe.mdmp
 [2005-07-09 21:52 UTC] derick@php.net
Please provide a link to: mywizzy.wsdl too.
 [2005-07-11 09:06 UTC] dmitry@php.net
I cannot reproduce bug without WSDL. You code works without WSDL (with PHP HEAD). I got string(21) "Hello 57573838574843." as result from your soap server.

Please provide "mywizzy.wsdl".
 [2005-07-11 19:13 UTC] gschlossnagle@php.net
I'll take this dmitry, if you don't mind.
 [2005-07-19 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC