php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33603 PHP Warning: Unknown():brary) 'hello.so'
Submitted: 2005-07-07 15:08 UTC Modified: 2005-07-07 15:11 UTC
From: ikrabbe dot ask at web dot de Assigned:
Status: Not a bug Package: *Web Server problem
PHP Version: 4.3.11 OS: linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: ikrabbe dot ask at web dot de
New email:
PHP Version: OS:

 

 [2005-07-07 15:08 UTC] ikrabbe dot ask at web dot de
Description:
------------
Trying to compile a hello.so extension comes down with a 
Invalid library (maybe not a PHP library). 
 
So I ask what qualifies a library to be a php library? 
 
phpize does the same as choosing own arguments which I 
really prefer over phpize, but as a first hit it would be 
ok to work with phpize. 
 
What symbols must exist to qualify my library ? 
  

Reproduce code:
---------------
config.m4
PHP_ARG_ENABLE(hello, whether to enable Hello World support,
 [ --enable-hello   Enable Hello World support])
 
 if test "$PHP_HELLO" = "yes"; then
   AC_DEFINE(HAVE_HELLO, 1, [Whether you have Hello World])
   PHP_NEW_EXTENSION(hello, hello.c, $ext_shared)
 fi

Example from http://www.zend.com/php/internals/extension-writing1.php#Heading5


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-07-07 15:11 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Please ask questions related to custom extensions in pecl-dev@lists.php.net.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Aug 15 19:05:44 2022 UTC