php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #33531 A critical file in the wrong dir
Submitted: 2005-07-01 04:59 UTC Modified: 2005-07-01 15:58 UTC
From: nerdshoe at satx dot rr dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 4.x OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: nerdshoe at satx dot rr dot com
New email:
PHP Version: OS:

 

 [2005-07-01 04:59 UTC] nerdshoe at satx dot rr dot com
Description:
------------
Quite a simple problem but it caused me lots of trouble since there are very few trouble shooting tools for the configuration files.

php4apache.dll is in the wrong directory and will not work if you follow the installation instructions for installing php as an apache module. If you were like me, you might have caught that after lots of wasted time and changed the path. But no, that didn't work. Took me another hour to try moving the file to the right directory and bingo, it works just fine now.

The sapi directory is clearly incorrect. Even if you change the path in your httpd.conf file, it still will not run. It must be put into c:/php or the root of your tree.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-07-01 15:56 UTC] nlopess@php.net
There is a note to php 4 users in the documentation to copy sapi/* file to C:\php.
 [2005-07-01 15:58 UTC] nlopess@php.net
I don't know how the title get changed...
 [2005-07-01 15:58 UTC] dave@php.net
Reverted erroneous title change.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Jun 15 11:01:24 2021 UTC