php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33522 Error sending array with SOAP-Client
Submitted: 2005-06-30 15:17 UTC Modified: 2005-10-11 18:02 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: blendien at basis-audionet dot de Assigned: dmitry (profile)
Status: Not a bug Package: SOAP related
PHP Version: 5CVS-2005-07-07 OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: blendien at basis-audionet dot de
New email:
PHP Version: OS:

 

 [2005-06-30 15:17 UTC] blendien at basis-audionet dot de
Description:
------------
Hi,

we use php 5.0.4 with SOAP-Extension for Debian.

Now we have the following problem, I must send an array via SOAP to an Axis-Engine and the Axis-Engine cannot understand the build xml.

So I get back this Message from Axis.

org.xml.sax.SAXException: No deserializer defined for array type {http://www.w3.org/2001/XMLSchema}long 

So we guess that php 5.0.4 makes anything wrong with the packing from an array to SOAP. It's equal which type the Array has. 

This artical is analog to http://bugs.php.net/bug.php?id=30352



Reproduce code:
---------------
$soap_client->call('deletePhonebookEntries', array($id,$pwd,array(1,2,3)));

<wsdl:message name="deletePhonebookEntriesRequest">
  <wsdl:part name="cust_id" type="xsd:long" /> 
  <wsdl:part name="cust_password" type="xsd:string" /> 
  <wsdl:part name="cust_phonebook_ids" type="impl:ArrayOf_xsd_long" /> 
  </wsdl:message>

<wsdl:message name="deletePhonebookEntriesResponse">
  <wsdl:part name="deletePhonebookEntriesReturn" type="xsd:long" /> 
  </wsdl:message>

<wsdl:operation name="deletePhonebookEntries" parameterOrder="cust_id cust_password cust_phonebook_ids">
  <wsdl:input message="impl:deletePhonebookEntriesRequest" name="deletePhonebookEntriesRequest" /> 
  <wsdl:output message="impl:deletePhonebookEntriesResponse" name="deletePhonebookEntriesResponse" /> 
  <wsdl:fault message="impl:SystemFault" name="SystemFault" /> 
  <wsdl:fault message="impl:ClientFault" name="ClientFault" /> 
  </wsdl:operation>



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-07-06 13:27 UTC] blendien at basis-audionet dot de
The problem still exists with the latest CVS.

I think it's a bug in the SOAP extension of PHP 5
 [2005-10-11 18:02 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

This does not follow SOAP specs.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC