|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33441 child pid xxxx exit signal Segmentation fault (11)
Submitted: 2005-06-23 03:44 UTC Modified: 2005-07-04 01:00 UTC
Avg. Score:3.8 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: bender at technofor dot us Assigned:
Status: No Feedback Package: Apache related
PHP Version: 4.4.0RC1 OS: FreeBSD 5.4-STABLE
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: bender at technofor dot us
New email:
PHP Version: OS:


 [2005-06-23 03:44 UTC] bender at technofor dot us
Hi . I just upgraded my php 4.4.0RC1 , but still have same problem :( Then I try open webmail like SquirrelMail and now I installed another php webmail still same server not crashing but it don't open the page . It shows the page cannot be displayed . And in the apache logs I see only this messeges 

[Wed Jun 22 16:35:39 2005] [notice] SIGHUP received.  Attempting to restart
[Wed Jun 22 16:35:39 2005] [warn] NameVirtualHost has no VirtualHosts
[Wed Jun 22 16:35:39 2005] [notice] FastCGI: process manager initialized (pid 48532)
[Wed Jun 22 16:35:40 2005] [notice] Microsoft-IIS/5.0 mod_fastcgi/2.4.2 mod_perl/1.29 PHP/4.4.0RC1 configured -- resuming normal operations
[Wed Jun 22 16:35:40 2005] [notice] suEXEC mechanism enabled (wrapper: /usr/local/sbin/suexec)
[Wed Jun 22 16:35:40 2005] [notice] Accept mutex: flock (Default: flock)
[Wed Jun 22 16:36:28 2005] [notice] child pid 48543 exit signal Segmentation fault (11)
[Wed Jun 22 17:01:02 2005] [notice] child pid 48537 exit signal Segmentation fault (11)
[Wed Jun 22 17:01:02 2005] [notice] child pid 48536 exit signal Segmentation fault (11)

And same happend then I try acces callendar on ipb it's shows only this error . Same problem I haved with php 4.3.11 But I wited until newer version in mind that this problem will go away . 
There is couple url with my core file and apache strace 

GDB Core :
Apache strace :

Btw it's apache 1.33 web server not microsoft it's just mod_security show like this . But I had the problem before mod_security was instaled so somthing else is wrong . Thanx for help . 


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2005-06-23 10:47 UTC]
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc.

If possible, make the script source available online and provide
an URL to it here. Try to avoid embedding huge scripts into the report.

 [2005-06-23 20:14 UTC]
We really need some reproduce script and/or gdb backtrace.
Please reopen the report when you have it.
 [2005-06-24 04:34 UTC] bender at technofor dot us
Ok. here I created bgd from the script's which I unable to run . In the url I created space between www and rest url .

First is webmail I created 2 files core and bgd 
Core: www.
gdb : www.

Callendar ( it required zend ) IPB 
Core: www.
gdb:  www.

One more program Tunez it's wont run too with the same error ... 
Core: www.
gdb:  www.

And I downgraded php back to the 4.3.11 becose zend not compatible with 4.4 . Im not sure how to create the script so I provide just gdb and core files . Core files I created in the SSH the typed php index.php . If need some mroe info let me know . 
 [2005-06-24 10:06 UTC]
Now please turn off ZendOptimizer and rebuild PHP with --enable-debug. 
Your backtraces doesn't contain any useful information, because you didn't read
 [2005-06-25 01:19 UTC] bender at technofor dot us
Ok. I just installed the 4.4.0RC1 again with --enable-debug and disabled zend optimizer if Im correct in php.ini file ? I comented out this lines :

Stoped and started apache after that .

And created new gdb and core files

Squire webmail 
Core :  www
gdb : www

Core: www
gdb : www

Core: www
gdb:  www

 [2005-06-25 09:35 UTC]
Obviously there is going something wrong, but it would really help us if you could come up with a short reproducable script. It seems related to user defined sessions, but can you recreate one of the backtrace where you have the session module compiled in statically (and not as a shared object)? (You also don't have to put the core files online, as they are useles without the system they were generated on).
 [2005-06-25 12:03 UTC] bender at technofor dot us
Hmm Im not sure how to create reproducible script . But If I shortened the mailbox.php script to this lines :
 * Find out the base URI to set cookies.
if (!function_exists('sqm_baseuri')){
    require_once(SM_PATH . 'functions/display_messages.php');
And did gdb it's will give me this output :

(gdb) bt
#0  0x080ca91e in _zval_ptr_dtor (zval_ptr=0x28a63928) at /usr/home/bender/php-4.4.0RC1/Zend/zend_execute_API.c:287
#1  0x080a493e in var_destroy (var_hashx=0x1) at /usr/home/bender/php-4.4.0RC1/ext/standard/var_unserializer.c:132
#2  0x28a5ce9b in ps_srlzr_decode_php () from /usr/local/lib/php/20020429/
#3  0x28a5d1ed in php_session_decode () from /usr/local/lib/php/20020429/
#4  0x28a5d522 in php_session_initialize () from /usr/local/lib/php/20020429/
#5  0x28a5ee15 in php_session_start () from /usr/local/lib/php/20020429/
#6  0x28a604e0 in zif_session_start () from /usr/local/lib/php/20020429/
#7  0x080e3f92 in execute (op_array=0x81f5300) at /usr/home/bender/php-4.4.0RC1/Zend/zend_execute.c:1671
#8  0x080e1bc0 in execute (op_array=0x81ccb0c) at /usr/home/bender/php-4.4.0RC1/Zend/zend_execute.c:1715
#9  0x080e2484 in execute (op_array=0x81cc00c) at /usr/home/bender/php-4.4.0RC1/Zend/zend_execute.c:2257
#10 0x080e2484 in execute (op_array=0x81c8d8c) at /usr/home/bender/php-4.4.0RC1/Zend/zend_execute.c:2257
#11 0x080e2484 in execute (op_array=0x81c8b0c) at /usr/home/bender/php-4.4.0RC1/Zend/zend_execute.c:2257
#12 0x080d3023 in zend_execute_scripts (type=8, retval=0x0, file_count=3) at /usr/home/bender/php-4.4.0RC1/Zend/zend.c:938
#13 0x080ac4b8 in php_execute_script (primary_file=0xbfbfebbc) at /usr/home/bender/php-4.4.0RC1/main/main.c:1751
#14 0x080eb34d in main (argc=2, argv=0xbfbfec3c) at /usr/home/bender/php-4.4.0RC1/sapi/cli/php_cli.c:828

After that I tryed to run display_messages.php but it don't crashes and don't give any gbd . 
Maybe I can give access to my server for you and you will better check what's wrong ? If this gdb dosen't help too much ... 
 [2005-06-26 12:42 UTC]
And next compile session extension statically into PHP.
(--enable-session without the =shared part!)

And REALLY come up with a SHORT reproducing script without any include/require, etc. external crap we have no access to.

 [2005-07-04 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2005-08-14 06:06 UTC] fred at gigaloo dot net
I had the same bug.

It's now solved by using this:
portupgrade -Rf php4-session
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue May 28 04:01:31 2024 UTC