php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3341 IMAP support compilation error
Submitted: 2000-01-28 17:04 UTC Modified: 2000-02-29 15:36 UTC
From: shevek at anarres dot org Assigned:
Status: Closed Package: IMAP related
PHP Version: 3.0.14 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: shevek at anarres dot org
New email:
PHP Version: OS:

 

 [2000-01-28 17:04 UTC] shevek at anarres dot org
One needs to fill the IMAP source tree with symlinks to get anyone to agree on where the c-client.a lives. It requires mail.h in DIR/c-client/include and libc-client.a in DIR/c-client/lib, whereas washington IMAP (freshly downloaded) makes c-client/mail.h and c-client/c-client.a without ceremony.

S.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-02-23 14:39 UTC] sas at cvs dot php dot net
And the problem is..?

Preparing the imap dir is easy:

1. ln -s c-client include
2. ln -s c-client lib
3. (cd lib && ln -s c-client.a libc-client.a)
 [2000-02-29 15:36 UTC] chagenbu at cvs dot php dot net
uw-imap freshly compiled doesn't work for anything other
than the other uw tools. Any package system (redhat, debian,
etc) installs the libs and headers in a consistent location.
No problem here...
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Dec 06 03:03:34 2021 UTC