php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33390 user notes need to be escaped
Submitted: 2005-06-18 03:15 UTC Modified: 2005-06-19 23:22 UTC
From: didou@php.net Assigned:
Status: Closed Package: Livedocs problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: didou@php.net
New email:
PHP Version: OS:

 

 [2005-06-18 03:15 UTC] didou@php.net
Description:
------------
Notes are not escaped :

http://livedocs.phpdoc.info/index.php?l=en&q=function.domxml-xslt-stylesheet


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-06-18 04:16 UTC] iliaa@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 [2005-06-18 05:41 UTC] didou@php.net
Still broken, see the first note here:

http://didou.keliglia.com/manuals/php/index.php?l=en&q=function.domxml-xslt-stylesheet

The problem is that the regexp doesn't match anything after the "?>" sequence in the XSL header. A fix would be to remove the preg_replace_callback() call and directly call highlight_php_code() if "<?" is detetcted by strpos().
 [2005-06-19 23:22 UTC] iliaa@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Apr 04 03:01:24 2020 UTC