php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33335 Create soap xml attribute
Submitted: 2005-06-14 10:56 UTC Modified: 2005-06-14 11:20 UTC
From: tt at tettnag dot com Assigned:
Status: Not a bug Package: SimpleXML related
PHP Version: 5.0.4 OS: Slackware 10
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: tt at tettnag dot com
New email:
PHP Version: OS:

 

 [2005-06-14 10:56 UTC] tt at tettnag dot com
Description:
------------
Why it doesn't print anything?
It seems to work where i do a print_r( $obj )
but te access to $obj->Header and so on is impossible.

Thank you

Reproduce code:
---------------
<?php

$xml = <<<XML
<?xml version="1.0"?>
<env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/">
<env:Header>
<mm7:TransactionID env:mustUnderstand="1" xmlns:mm7="http://www.3gpp.org/ftp/Specs/archive/23_series/23.140/schema/REL-5-MM7-1-0">how-</mm7:TransactionID></env:Header>
<env:Body>
<mm7:SubmitRsp xmlns:mm7="http://www.3gpp.org/ftp/Specs/archive/23_series/23.140/schema/REL-5-MM7-1-0">
<MM7Version>5.3.0</MM7Version>
<Status>
<StatusCode>2007</StatusCode>
<StatusText>The MM7 request is incorrect</StatusText>
</Status>
<MessageID>101118737629315669</MessageID>
</mm7:SubmitRsp>
</env:Body>
</env:Envelope>
XML;

$obj = simplexml_load_string( $xml );
print_r( $obj->Header->TransactionId );

?>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-06-14 11:12 UTC] tt at tettnag dot com
Ok. Now I understand by myself. I have to access with $obj->Children( "namespace" ).

I'm Sorry ;
 [2005-06-14 11:20 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Dec 07 04:05:52 2022 UTC